WWW pro školy
Jak na Office - tutoriály, video návody











Vytvoř si  geekové tričko

Poradna - Sečtení dní podle datumu

hlavní kategorie | zpět | + odpovědět na toto téma
Sečtení dní podle datumu - diskuze na toto téma
Zdravím, Poprosím o radu. Mám různé datumy ve sloupcích A1 až A87 jdoucí po sobě, tzn. začínám 27.4.2018 a vzestupně končím dnes 26.9.2018, přičemž některé datumy se pod sebou opakují. Rád bych, aby se mi do jedné buňky zapisoval počet dní, tzn. aby vzorec bral opakující se datumy jako jeden den a pokud by to bylo možné, aby se dal rozšířit i na další prázdné buňky, do kterých se datum teprve zapíše. Šlo by to udělat nějakou jednoduchou funkcí? Děkuji

MePExG | 26.9.2018 21:26  
 
 
Prikladám moje riešenie pomcou pomocného stĺpca aj kt. Išlo by to asi aj pomocou jedného maticového vzorca.
Odpověď
elninoslov | 26.9.2018 21:40  
 
 
=SUMPRODUCT(1/COUNTIF(Table1[Datum];Table1[Datum]))
Odpověď
elninoslov | 26.9.2018 21:43  
 
 
=SUM(--(FREQUENCY(Table1[Datum];Table1[Datum])>0)) Zdroj : vzorec pochádza odtiaľto https://exceljet.net/formula/count-unique-numeric-values-in-a-range
Odpověď
Lobo | 26.9.2018 21:43  
 
 
=SOUČIN.SKALÁRNÍ(1/COUNTIF(A1:A87;A1:A87)) Pro data ve sloupci A
Odpověď
Lobo | 26.9.2018 21:47  
 
 
Elnino byl rychlejší :-(
Odpověď
Stepan | 26.9.2018 21:45  
 
 
Děkuji, už jsem to vyřešil podle vzorce: =SUMA(KDYŽ(ČETNOSTI(B4:B200;B4:B200)>0;1))
Odpověď