WWW pro školy
Jak na Office - tutoriály, video návody











Vytvoř si  geekové tričko

Poradna - vyhledat a sečíst více buněk v řádku

hlavní kategorie | zpět | + odpovědět na toto téma
vyhledat a sečíst více buněk v řádku - diskuze na toto téma
Potřebuji ve sloupci A,B,C sečíst hodnoty, sloupec D jsou kritéria vyhledávám přez bunku E1.Použil jsem pro sečtení více buněk ve stejném řádku tento poskládaný vzorec =SUMIFS(A1:A5;D1:D5;E1)+SUMIFS(B1:B5;D1:D5;E1)+SUMIFS(C1:C5;D1:D5;E1) příjde mi to docela složité. Nexzistu je pro toto sčítaní jiná možnost?

elninoslov | 20.2.2018 08:32  
 
 
=SUMPRODUCT((A1:C5)*(D1:D5=E1)) v CZ to bude =SOUČIN.SKALÁRNÍ((A1:C5)*(D1:D5=E1))
Odpověď
elninoslov | 20.2.2018 08:34  
 
 
Alebo maticový vzorec (Ctrl+Shift+Enter) =SUM((A1:C5)*(D1:D5=E1)) v CZ to bude =SUMA((A1:C5)*(D1:D5=E1))
Odpověď
LUD | 20.2.2018 20:14  
 
 
DĚKUJI jak jednoduché. Dá se tento vzorec rozšířit ještě o jeden sloupec s krýtérii. Abych mohl vyhledávat pomocí dvou podmínek.
Odpověď
elninoslov | 21.2.2018 00:57  
 
 
Priložte príklad - prílohu, kde bude ukázané čo chcete. Určo nájdeme riešenie.
Odpověď
lud | 21.2.2018 20:50  
 
 
přikládám tabulku vše je popsáno na listě Lisování. Vzorc mi funguje jen mi příjde moc složítý. rád bych ho zjednodušil. =SUMIFS(Čištění!G$11:G$92;Čištění!$B$11:$B$92;B11;Čištění!$C$11:$C$92;C11)+SUMIFS(Čištění!H$11:H$92;Čištění!$B$11:$B$92;B11;Čištění!$C$11:$C$92;C11)+SUMIFS(Čištění!I$11:I$92;Čištění!$B$11:$B$92;B11;Čištění!$C$11:$C$92;C11)
Odpověď
elninoslov | 21.2.2018 22:05  
 
 
Príloha mi nejde stiahnuť ("404 Page Not Found")
Odpověď
lud | 21.2.2018 22:15  
 
 
Znovu a lepe
Odpověď
lud | 21.2.2018 22:17  
 
 
tak nevým co dělám špatně, soubor ma velikost 175kb. zkusím to zítra
Odpověď
lud | 22.2.2018 05:03  
 
 
-
Odpověď
lud | 22.2.2018 05:05  
 
 
-
Odpověď
lud | 22.2.2018 05:07  
 
 
-
Odpověď
lud | 22.2.2018 05:09  
 
 
poslední odkaz funguje. asi byl příliš dlouhý název.
Odpověď
elninoslov | 22.2.2018 09:30  
 
 
Ten Váš vzorec na PF nieje zlý. Dá sa to napr. aj inak, viď príloha. No a ten SUMPRODUCT by bol asi takto.
Odpověď
lud | 22.2.2018 18:13  
 
 
Moc díky, dobrý vzorec. A já to vždy dělám tak složitě, když to jde jednoduše.
Odpověď