WWW pro školy
Jak na Office - tutoriály, video návody











Vytvoř si  geekové tričko

Poradna - SUMIF se dvěmi podmínkami

hlavní kategorie | zpět | + odpovědět na toto téma
SUMIF se dvěmi podmínkami - diskuze na toto téma
Zdravím, nevím si rady se složitější funkcí SUMIF. Vysvětlím, co tabulka níže má udělat: Listy: Data - vypsaná tabulka s hodnotami, ve sloupci "Datum úpravy" je načítána hodnota funkcí SVYHLEDAT z vedlejšího listu Historie kampaně - Pro každou unikátní hodnota ve sloupci "Spojení" se každý den načte nová hodnota s aktuálním datumem a číselnou hodnotou ve sloupci Clicks Funkcí SUMIF chci sečíst všechny hodnoty ze sloupce "Clicks" v listu historie kampaně, ale až od data uvedeného ve sloupci "Datum úpravy" a zároveň se musí shodovat hodnota ze sloupce "Spojení". Odkaz na tabulku: https://docs.google.com/spreadsheets/d/1dn-PmWUQCXJTrv3WaZB5Sy9l2901qUs43gCixStFCAU/edit?usp=sharing

elninoslov | 5.7.2018 08:54  
 
 
Druhý krát vkladajte normálnu tabuľku, upraviteľnú, nie zamknutú. Nech si to ten, kto Vám chce poradiť, nemusí vytvárať všetko sám. =SUMIFS('Historie kampaně'!G:G;'Historie kampaně'!A:A;Data!A2;'Historie kampaně'!B:B;">="&Data!F2)
Odpověď
Tomáš | 9.7.2018 09:35  
 
 
Super, moc jste pomohl. Poslední problém v tabulce je, že SVYHLEDAT nevyhledává přesnou shodu, přestože je funkce takto definována. =SVYHLEDAT(A2;'Zadání datum'!A:E;5;0), přesto uvádí v mém případě chybné hodnoty a to například pro řádek 1 viz. níže vypíše hodnotu č.2 Řádek č.1 - brand==znacka1&+product_type_l1== Řádek č.2 - brand==znacka1&+product_type_l1==elektronika | foto | foto doplňky a příslušenství | stativy&+id==*
Odpověď
elninoslov | 9.7.2018 15:02  
 
 
To si robíte prču, nie ? Hneď prvú vetu Vám píšem, že máte priložiť prílohu, aby sme vedeli, čo tam kde ako máte, a mohli sme si riešenie odladiť na dátach, a nie že si máme pre Vás dáta vymýšľať sami. A Vy nielenže nevložíte prílohu, ale ešte sa opýtate prečo nefunguje vzorec, o ktorom nikto okrem Vás netuší kde sa nachádza, aké dáta prehľadáva, zoradené, nezoradené, správne stĺpce či nie, proste nič, lebo taký list "Zadání datum" ani v (aj tak nepoužiteľnej) ukážke nemáte. Keď sa pozriete na to, ako vyzerá Váš posledný príspevok (to blbá vlastnosť tohto fóra), tak musíte uznať, že z neformátovaného zlúčeného popisu stĺpcov a riadkov sa nedá identifikovať, o čom presne hovoríte. Vložte Excelácku prílohu, a pozrieme sa nato. Musíte trochu spolupracovať... :)
Odpověď