WWW pro školy
Jak na Office - tutoriály, video návody











Vytvoř si  geekové tričko

Poradna - vyhledání hodnoty v seznamu

hlavní kategorie | zpět | + odpovědět na toto téma
vyhledání hodnoty v seznamu - diskuze na toto téma
Dobrý den, potřebuji, aby vzorec ověřil zda v seznamu položek ve sloupci A je daná hodnota či nikoli. A to v libovolném řádku. Výstup stačí pouze ano/ne. Děkuji.

Maximus | 12.6.2018 12:27  
 
 
Např: SVYHLEDAT, také stačí použit filtr
Odpověď
excel | 12.6.2018 12:43  
 
 
svyhledat prohledá první sloupec a doplňuje hodnoty z druhého nebo dalšího. Mě by stačilo, kdyby jen vzorec ověřil zda se hodnota ve sloupci nachází a vrátil např. ano v opačném případě ne. Pokud se mi hodnota ve sloupci nenachází hází mi svyhledat chybovou hlášku.
Odpověď
Maximus | 12.6.2018 12:56  
 
 
Tak použijte funkci KDYŽ
Odpověď
excel | 12.6.2018 13:06  
 
 
No a dá se funkce KDYŽ použít na oblast? Příklad potřebuju porovnat zda se hodnota v C1 vyskytuje ve sloupci A. =KDYŽ(C1=A:A;ano;ne) Toto mi ale hodí chybu.
Odpověď
Maximus | 12.6.2018 13:08  
 
 
Do C1 dát tento vzorec a do B1 dát hledanou hodnotu =IFERROR(KDYŽ(POZVYHLEDAT(B1;A:A;0)>0;"a";"n");"n")
Odpověď
Maximus | 12.6.2018 13:24  
 
 
Stačí i takto =IFERROR(POZVYHLEDAT(B1;A:A;0)>0;"NEPRAVDA")
Odpověď
elninoslov | 12.6.2018 13:32  
 
 
Použite toto isté : pc-help.cnews.cz/viewtopic.php?f=35&t=200000
Odpověď
excel | 12.6.2018 14:00  
 
 
Děkuji, to je přesně ono.
Odpověď