WWW pro školy
Jak na Office - tutoriály, video návody











Vytvoř si  geekové tričko

Poradna - Funkce KDYŽ s funkcí DOSADIT

hlavní kategorie | zpět | + odpovědět na toto téma
Funkce KDYŽ s funkcí DOSADIT - diskuze na toto téma
=KDYŽ(I3 = „Y“; =DOSADIT(G3; „$“ ; „“ )) Proč mi to nefunguje? Snažím se o to aby podle textu v určité buňce (I3 je „y“) tak aby to v jiné buňce (G3) smazalo všechny kotvy (jestli se tomu tak říká)

elninoslov | 27.5.2018 19:20  
 
 
A odkiaľ berie tá bunka G3 ten text v ktorom sa nachádzajú $? Nemôžete totiž odstrániť $ z G3 samotnou G3. Teda ak G3 čerpá dáta odinakiaľ, tak nieje problém. Ak by teda G3 čerpala text napr. z E3, tak do G3 pôjde =IF(I3="y";SUBSTITUTE(E3;"$";"");E3) v SK, a v CZ je to =KDYŽ(I3="y";DOSADIT(E3;"$";"");E3)
Odpověď
Samuel Zvířecí | 27.5.2018 19:26  
 
 
Ano, chápu.. V buňce G3 je vzorec =SUMA(E$3:E;F$3:F) a když je splněná podmínka nechci aby tam ty $ byli Ale chápu že se funkce DOSADIT nedostane k té funkci ale bude upravovat vypočítané číslo
Odpověď
elninoslov | 27.5.2018 20:32  
 
 
Vložte sem súbor, ktorého sa to týka. Lebo vidím, že vy nechcete z nejakého textu vymazať $, ale vy chcete pravdepodobne vzorcom zmeniť adresovanie vzorca (absolútne adresovanie na relatívne). Podľa prílohy sa to možno bude dať nejako vyriešiť (napr. aj pomocou INDEX/OFFSET a pod.). Proste dajte prílohu.
Odpověď